Nissan Qashqai Owners Club UK Homepage
Forum Home Forum Home > J11 Qashqai 2014 - > J11 Gallery
  New Posts New Posts RSS Feed - COOLING FAN TROUBLES
  FAQ FAQ  Forum Search   Register Register  Login Login

COOLING FAN TROUBLES

 Post Reply Post Reply
Author
Message
firestick View Drop Down
Forecourt
Forecourt


Joined: 19 Jul 2020
Location: Ireland
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote firestick Quote  Post ReplyReply Direct Link To This Post Topic: COOLING FAN TROUBLES
    Posted: 19 Jul 2020 at 9:09am
Hi Everyone, i own a 14 plate nissan qasqai teckna, diesel engine.

For two years now, i have been entangled with a cooling fan issue. Whenever i park the car and turn off the engine, the cooling fan runs. this is regardless of how short the journey was which includes school run of about 10mins total drive.

If i use the car on a motorway on a 30mins drive which is usually my commute to work, the cooling fan runs after turn off until the battery is dead, hence making me carry jump starter kit in my car, i cant recall how many times i have had to jump start my car....countless times.

i have been to so many independent electricians, dpf cleaners, nissan mechanics, after all diagnosis and scan costing me lots of money, everyone says no error code was found in your car hence no repairs made yet except money on consultation and diagnosis thrown away, buy a new battery was the last verdict i had.

I purchased a new battery with 4 yrs warranty 2 weeks ago, still battery went dead cos cooling fan wont stop by its self after kicking on, have had to return two batteries under warranty within two weeks, am on a third pair they re-issued me.

Sometimes the fan wont run when i turn off the engine, but few feets away to the staircase, i would hear the fan come one and blowing quite speedy or loud if i may say.

I love my car, don't want to sell it, i want to solve the problem. A sympathethic electrician advised i change the fan control module, thats gona cost me money, so am here looking for someone who must have had similar issues to know how they fixed it.


Thanks
Back to Top
Udo2009 View Drop Down
Tekna
Tekna
Avatar

Joined: 04 Mar 2015
Location: Germany
Status: Offline
Points: 1262
Post Options Post Options   Thanks (0) Thanks(0)   Quote Udo2009 Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jul 2020 at 10:30am
This issue was also mentioned in another forum. Although there was no fix offered.

However... someone told about a software update which should fix the prolonged running of the fan.
Someone other mentioned a dropped off tube, after re-attaching it the the running of the fan didn't occur any more.
Coolant and oil are at the recommended levels?
Qashqai Acenta, 2,0 dCi, 110 kW, DPF, Euro5, black Z11G
Back to Top
pstahel View Drop Down
Forecourt
Forecourt
Avatar

Joined: 18 Jul 2020
Location: BRISTOL
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote pstahel Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jul 2020 at 10:43am
Is the fan running when you start it or is it when the engine is up to temp. 

I can,t believe a electrian or mechanics with computers can,t find a fix to this.

See if you can find a kit on line that can kick in the fan when too hot and cuts off when cooler. Surely the car has a thermostat and if so this is faulty , its got to be this as this only opens when the coolant is up to temp ??

I have,nt a manual so i can,t look up but see if theres a electrical drawing on the internet of the car and find the thermostat. 
Back to Top
pstahel View Drop Down
Forecourt
Forecourt
Avatar

Joined: 18 Jul 2020
Location: BRISTOL
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote pstahel Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jul 2020 at 10:58am
hI Again,

I have looked at youtube with this issue.

1/ IT COULD A RELAY WHAT CONTROLS THE FAN .

2 ITS THE TEMPERTURE SENSOR WHICH IS FAULTY

If you go on the internet and find the fuse and relay drawing this will tell you which relay controls the fan . Idea is , you remove the relay and and swop this with a relay which does,nt do much , ( not critical ) and see if the fan comes on . If it comes on then its the temp sensor , if not then its the relay.

I have a 14 plate 1.5 dci Acenta . MY MISSES IS AT WORK so when she gets back i will look in my cars owners manual and see if i can get the relay for you. Be this afternoon.  
Back to Top
Doug999 View Drop Down
Tekna
Tekna
Avatar

Joined: 20 Jun 2011
Location: Swansea
Status: Offline
Points: 1320
Post Options Post Options   Thanks (0) Thanks(0)   Quote Doug999 Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jul 2020 at 2:33pm
The cooling fan is controlled by a coolant resistor and thermostat.  Both are easily removed/replaced.  The relays are situated in the engine fuse box. (2007-2012 models as shown in my Haynes Manual)
2012 Tekna 1.6L, Arctic White, Stone Leather
Back to Top
firestick View Drop Down
Forecourt
Forecourt


Joined: 19 Jul 2020
Location: Ireland
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote firestick Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jul 2020 at 10:23pm
Thanks, yes coolant is in optimum levels, have had to drain and replace a fresh batch, car was recently serviced. didnt know the car software can be updated? how is that done
Back to Top
firestick View Drop Down
Forecourt
Forecourt


Joined: 19 Jul 2020
Location: Ireland
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote firestick Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jul 2020 at 10:25pm
Fan runs only when engine is hot, just runs too long till battery is dead or i kick start the engine inbetween the runs
Back to Top
firestick View Drop Down
Forecourt
Forecourt


Joined: 19 Jul 2020
Location: Ireland
Status: Offline
Points: 5
Post Options Post Options   Thanks (0) Thanks(0)   Quote firestick Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jul 2020 at 10:31pm
Thank you so much
Back to Top
Udo2009 View Drop Down
Tekna
Tekna
Avatar

Joined: 04 Mar 2015
Location: Germany
Status: Offline
Points: 1262
Post Options Post Options   Thanks (0) Thanks(0)   Quote Udo2009 Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jul 2020 at 7:28am
Originally posted by firestick firestick wrote:

Thanks, yes coolant is in optimum levels, have had to drain and replace a fresh batch, car was recently serviced. didnt know the car software can be updated? how is that done


At the dealer's
Qashqai Acenta, 2,0 dCi, 110 kW, DPF, Euro5, black Z11G
Back to Top
pstahel View Drop Down
Forecourt
Forecourt
Avatar

Joined: 18 Jul 2020
Location: BRISTOL
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote pstahel Quote  Post ReplyReply Direct Link To This Post Posted: 21 Jul 2020 at 11:24am
Like i say , check the relay. if not that then its the sensor. Its obvious that one of the two isn,t doing its job. But get it sorted as its no good draining the battery out all the time

I have looked in my handbook and it does,nt show the fuse and relay diagram . its the one under the bonnet though.


Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.

This page was generated in 0.109 seconds.